吾愛破解 - LCG - LSG |安卓破解|病毒分析|001aa.com

 找回密碼
 注冊[Register]

QQ登錄

只需一步,快速開始

搜索
查看: 1478|回復: 11

[KeyGenMe] 一個有點難度的易語言KeyGenME,歡迎大佬Crack

[復制鏈接]
樓主
xieyi1393 發表于 2020-5-21 21:15 回帖獎勵
CM是什么?Crackme是什么?這是什么東西?樓主發的什么?
他們都是一些公開給別人嘗試破解的小程序,制作 Crackme 的人可能是程序員,想測試一下自己的軟件保護技術,也可能是一位 Cracker,想挑戰一下其它 Cracker 的破解實力,也可能是一些正在學習破解的人,自己編一些小程序給自己破解,KeyGenMe是要求別人做出它的 keygen (序號產生器), ReverseMe 要求別人把它的算法做出逆向分析, UnpackMe 是要求別人把它成功脫殼,本版塊禁止回復非技術無關水貼。

本帖最后由 xieyi1393 于 2020-5-21 22:44 編輯

測試用戶名:xieyi1393
測試序列號:640A0C83AADCC5E88A741CEB1F9DE9C9
正確彈出"注冊成功,歡迎使用"
錯誤彈出“注冊碼不對哦”
獎勵40CB,僅限首位CRACK
注意:提交時請同時提交KeyGen代碼,否則無效!
藍廋(奏)云:http://xieyi1393.lanzous.com/icvditi

易語言編寫,可能報毒
不要爆破!
注意:提交時請同時提交KeyGen代碼,否則無效!

免費評分

參與人數 4吾愛幣 +9 熱心值 +4 收起 理由
印象主義協會 + 1 + 1 我很贊同!
dreamlivemeng + 1 + 1 鼓勵轉貼優秀軟件安全工具和文檔!
CrazyNut + 6 + 1 下次請帶上成功截圖
為之奈何? + 1 + 1 我很贊同!

查看全部評分

發帖前要善用論壇搜索时时彩平台功能,那里可能會有你要找的答案或者已經有人發布過相同內容了,請勿重復發帖。

banik123 發表于 2020-5-22 00:09
.版本 2
.支持庫 dp1

.子程序 getkey, 文本型
.參數 名稱, 文本型
.局部變量 a, 文本型
.局部變量 i, 整數型
.局部變量 c, 文本型

i = 1
a = 取數據摘要 (到字節集 (“吾愛破解|LCG|LSG|xieyi1393|http://001aa.com/home.php?mod=space&uid=1397448” + 名稱 + “0吾愛破解”))
.判斷循環首 (i < 40960)
    .如果 (i % 3 = 0)
        a = 取數據摘要 (到字節集 (a + 名稱 + 到文本 (i) + “吾愛破解”))
    .否則
        .如果 (i % 3 = 1)
            a = 取數據摘要 (到字節集 (a + 名稱 + 到文本 (i) + “LCG”))
        .否則
            .如果 (i % 3 = 2)
                a = 取數據摘要 (到字節集 (a + 名稱 + 到文本 (i) + “LSG”))
            .否則

            .如果結束

        .如果結束

    .如果結束
    i = i + 1
.判斷循環尾 ()
' 調試輸出 (字節集_還原 (a))
a = 取數據摘要 (到字節集 (“H@” + a))
a = 取數據摘要 (到字節集 (“e@” + a))
a = 取數據摘要 (到字節集 (“y@” + a))
a = 取數據摘要 (到字節集 (“!@” + a))
a = 取數據摘要 (到字節集 (“Y@” + a))
a = 取數據摘要 (到字節集 (“o@” + a))
a = 取數據摘要 (到字節集 (“u@” + a))
a = 取數據摘要 (到字節集 (“ @” + a))
a = 取數據摘要 (到字節集 (“F@” + a))
a = 取數據摘要 (到字節集 (“o@” + a))
a = 取數據摘要 (到字節集 (“u@” + a))
a = 取數據摘要 (到字節集 (“n@” + a))
a = 取數據摘要 (到字節集 (“d@” + a))
a = 取數據摘要 (到字節集 (“ @” + a))
a = 取數據摘要 (到字節集 (“T@” + a))
a = 取數據摘要 (到字節集 (“h@” + a))
a = 取數據摘要 (到字節集 (“e@” + a))
a = 取數據摘要 (到字節集 (“ @” + a))
a = 取數據摘要 (到字節集 (“H@” + a))
a = 取數據摘要 (到字節集 (“i@” + a))
a = 取數據摘要 (到字節集 (“d@” + a))
a = 取數據摘要 (到字節集 (“d@” + a))
a = 取數據摘要 (到字節集 (“e@” + a))
a = 取數據摘要 (到字節集 (“n@” + a))
a = 取數據摘要 (到字節集 (“ @” + a))
a = 取數據摘要 (到字節集 (“K@” + a))
a = 取數據摘要 (到字節集 (“e@” + a))
a = 取數據摘要 (到字節集 (“y@” + a))
a = 取數據摘要 (到字節集 (“!@” + a))
a = 取數據摘要 (到字節集 (“J@” + a))
a = 取數據摘要 (到字節集 (“u@” + a))
a = 取數據摘要 (到字節集 (“s@” + a))
a = 取數據摘要 (到字節集 (“t@” + a))
a = 取數據摘要 (到字節集 (“ @” + a))
a = 取數據摘要 (到字節集 (“W@” + a))
a = 取數據摘要 (到字節集 (“r@” + a))
a = 取數據摘要 (到字節集 (“i@” + a))
a = 取數據摘要 (到字節集 (“t@” + a))
a = 取數據摘要 (到字節集 (“e@” + a))
a = 取數據摘要 (到字節集 (“ @” + a))
a = 取數據摘要 (到字節集 (“K@” + a))
a = 取數據摘要 (到字節集 (“e@” + a))
a = 取數據摘要 (到字節集 (“y@” + a))
a = 取數據摘要 (到字節集 (“G@” + a))
a = 取數據摘要 (到字節集 (“e@” + a))
a = 取數據摘要 (到字節集 (“n@” + a))
a = 取數據摘要 (到字節集 (“ @” + a))
a = 取數據摘要 (到字節集 (“N@” + a))
a = 取數據摘要 (到字節集 (“o@” + a))
a = 取數據摘要 (到字節集 (“w@” + a))
a = 取數據摘要 (到字節集 (“!@” + a))
c = a
a = 取數據摘要 (到字節集 (“PHP是世界上最好的語言,吾愛是世界上最牛X的PJ論壇” + a))
.判斷循環首 (取文本左邊 (a, 2) ≠ “88”)
    a = 取數據摘要 (到字節集 (a))
.判斷循環尾 ()
a = 取數據摘要 (到字節集 (a + “001aa.com”))
.判斷循環首 (取文本左邊 (a, 2) ≠ “66”)
    a = 取數據摘要 (到字節集 (a))

.判斷循環尾 ()
a = 取數據摘要 (到字節集 (a + c + “XIEYI1393”))
.判斷循環首 (取文本左邊 (a, 1) ≠ “4”)
    a = 取數據摘要 (到字節集 (a))

.判斷循環尾 ()
a = 取數據摘要 (到字節集 (a + “REDSTONEFUN”))
.判斷循環首 (取文本左邊 (a, 2) ≠ “64”)
    a = 取數據摘要 (到字節集 (a))

.判斷循環尾 ()

返回 (到大寫 (a))

 樓主| xieyi1393 發表于 2020-5-22 00:26 |樓主
本帖最后由 xieyi1393 于 2020-5-22 00:29 編輯
banik123 發表于 2020-5-22 00:09
.版本 2
.支持庫 dp1

KeyGen看上去沒問題(由于電腦關機了)
各個Point也給找出來了(主要是利用數組隱藏的一組給找出來了)
只是這個KeyGen其實可以寫的簡潔一點(多用點循環)
不過,請查收40CB:
http://001aa.com/thread-1184142-1-1.html
推薦
隕落星辰 發表于 2020-5-21 22:07
本帖最后由 隕落星辰 于 2020-5-21 22:34 編輯


不要CB 先手爆破
選中地址處改nop 即可

更新時間:2020.5.21 22點33分
能把KEY追出來我就懶得追算法了

賬號:隕落星辰
KEY:64076CA353A2D3CD3275AFC236FDC76A
3#
跌宕起伏 發表于 2020-5-21 22:38

Patches
地址       大小   狀態      舊                                新                                注釋
00401293     2.   激活        ???                               jmp XKeyGenMe.004012E3        CDKEY為32位大寫字母/數字
0040240F     6.   激活        je KeyGenMe.0040245F              nop                 注冊成功
除了加了殼加了花感覺難度不大
4#
 樓主| xieyi1393 發表于 2020-5-21 22:42 |樓主
隕落星辰 發表于 2020-5-21 22:07
不要CB 先手爆破
選中地址處改nop 即可

Key正確,請給出KeyGen代碼
5#
 樓主| xieyi1393 發表于 2020-5-21 22:43 |樓主
跌宕起伏 發表于 2020-5-21 22:38
Patches
地址       大小   狀態      舊                                新                          ...

請給出KeyGen代碼
6#
basstk 發表于 2020-5-21 23:27
都是大佬.學習了
9#
Light紫星 發表于 2020-5-22 10:46
banik123 發表于 2020-5-22 00:09
.版本 2
.支持庫 dp1

大佬是怎么搞出來源碼的
10#
a110pk147 發表于 2020-5-22 15:18
都(與)是(我)大(無)佬(關)
您需要登錄后才可以回帖 登錄 | 注冊[Register]

本版積分規則 警告:本版塊禁止回復與主題無關非技術內容,違者重罰!

快速回復 收藏帖子 返回列表 搜索

RSS訂閱|小黑屋|聯系我們|吾愛破解 - LCG - LSG ( )

GMT+8, 2020-5-25 06:11

Powered by Discuz!

Copyright © 2001-2020, Tencent Cloud.

快速回復 返回頂部 返回列表
时时彩平台官网-欢迎您 时时彩平台注册-爱问知识人 时时彩平台app-互动百科 时时彩平台投注-百科词条 超级快三-搜霸天下 时时彩平台邀请码-即可搜索 时时彩平台开户-新浪爱彩 彩神大发快三-一定牛 彩神大发快三官网-360云盘 彩神大发快三注册-百度耨米